Home Forums RaidPlanner Discussions Bug reports Raidplanner 0.6.0 Guild Assignment problem

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #920
    Anonymous
    Inactive

    Hi Taracque,

    I was using the BETA version before you have released 0.6.0. As I would now update my installation to 0.6.0 I go to my joomla extension manager (J2.5) and have deinstalled 4 plugins/components from my joomla installation. Afterwards I have downloaded the new 0.6.0 and installed it. This works so far.

    Now I would like to add my guild. So I went to “Components” –> “Raidplanner” –> “Guilds” –> “New”

    I have only the opportunities to add the guildname, sync module (wow_armory) and to pick up “sync now”. There is no option to add the realm or region.

    When I add my guildname and choose wow_armory (and pick up sync now) and afterwards to to save I got the message “Guild saved” but the list is empty.

    I was using FF 8.0.1 and have a Joomla 2.5 installation.

    Maybe you can help me.

    Thanks and best regards,
    Endrei

    #921
    Anonymous
    Inactive

    Same problem with IE 8 … only fyi

    #922
    Taracque
    Member

    I see the problem, will fix it soon.
    As a workaround you can do the followings:
    Enter the guild name, and select wow_armory plugin, and press save & close button. Your guild should be in the list, and if you open you can edit the armory sync settings.

    Usually you don’t have to remove Raidplanner before upgrade, just install the new version over the old one will update everything (in theory)

    • This reply was modified 9 years, 5 months ago by Taracque.
    #926
    Anonymous
    Inactive

    I tried the workaround on 0.6.1 and it did not work. My guild list is empty. It was there prior to upgrading from 0.5.8 to 0.6.1. Just letting ya know. 🙂

    #927
    Taracque
    Member

    Can you please check your database structure?
    In raidplanner_guild table there should be a sync_plugin column. If it’s not there you have to run the following sql commands in you database:

    ALTER TABLE `jos_raidplanner_guild` DROP `guild_level`, DROP `guild_region`;
    ALTER TABLE `jos_raidplanner_guild` CHANGE `guild_realm` `sync_plugin` VARCHAR( 80 ) NOT NULL DEFAULT ”;

    (the above sql command are valid if you table prefix is jos_ in other cases please replace it with your table prefix)

    Please post the result to let me fix it asap.

    #928
    Anonymous
    Inactive

    The sync_plugin field is there, and populated with my server.
    There was a second entry in there from when I tried the workaround, but I removed it.

    guild_id 1
    guild_name Twisted Mayhem
    sync_plugin Bladefist
    lastSync 4/20/2012 21:46
    params (edited out due to length)

    guild_id 2
    guild_name Twisted Mayhem
    sync_plugin wow_armory
    lastSync (empty)
    params (empty)

    http://wowtwistedmayhem.com/images/raidplanner.png

    #929
    Anonymous
    Inactive

    Since you’re changing guild_realm to sync_plugin, where are we going to specify the realm the guild is on?

    #930
    Taracque
    Member

    Uhm, that looks weird. realm and region are now stored in params instead of separate fields (this is because syncing are made by plugins now, and different games uses different settings)
    Please turn on Debug system in your Global Configuration / System, and then go to RaidPlanner / Guilds page.
    Please copy queries from the Database Queries where raidplanner tables are used.

    #931
    Anonymous
    Inactive

    Looks like you have jos_ prefix hardcoded in the code at:
    administrator\components\com_raidplanner\models\guilds.php line 96.

    And I guess for my other question, I understand a plugin will handle the request now, but when setting it up for the first time, you’re only asking for the guild name. If there’s multiple guilds with the same name on different realms, how is the plugin going to know which one to choose without putting it manually in the params DB?

    JDatabaseMySQLi::query: 1146 - Table 'wowtm2.jos_raidplanner_guild' doesn't exist SQL=SELECT guild.*,(SELECT COUNT(character_id) FROM jos_raidplanner_character WHERE guild_id=guild.guild_id) AS members FROM jos_raidplanner_guild AS guild LIMIT 0, 20

    Return to Control Panel

    Call stack
    # Function Location
    1 JAdministrator->dispatch() C:\inetpub\wow\administrator\index.php:46
    2 JComponentHelper::renderComponent() C:\inetpub\wow\administrator\includes\application.php:153
    3 JComponentHelper::executeComponent() C:\inetpub\wow\libraries\joomla\application\component\helper.php:357
    4 require_once() C:\inetpub\wow\libraries\joomla\application\component\helper.php:388
    5 JController->execute() C:\inetpub\wow\administrator\components\com_raidplanner\raidplanner.php:37
    6 RaidPlannerController->display() C:\inetpub\wow\libraries\joomla\application\component\controller.php:754
    7 JController->display() C:\inetpub\wow\administrator\components\com_raidplanner\controller.php:31
    8 RaidPlannerViewGuilds->display() C:\inetpub\wow\libraries\joomla\application\component\controller.php:715
    9 JView->get() C:\inetpub\wow\administrator\components\com_raidplanner\views\guilds\view.html.php:30
    10 RaidPlannerModelGuilds->getData() C:\inetpub\wow\libraries\joomla\application\component\view.php:482
    11 JModel->_getList() C:\inetpub\wow\administrator\components\com_raidplanner\models\guilds.php:110
    12 JDatabase->loadObjectList() C:\inetpub\wow\libraries\joomla\application\component\model.php:319
    13 JDatabaseMySQLi->query() C:\inetpub\wow\libraries\joomla\database\database.php:1071
    14 JError::raiseError() C:\inetpub\wow\libraries\joomla\database\database\mysqli.php:396
    15 JError::raise() C:\inetpub\wow\libraries\joomla\error\error.php:251

    #932
    Anonymous
    Inactive

    After I changed the jos_ to #_ in the code it pulls the guild list fine and sync’d successfully. I changed the sync_plugin to wow_armory manually and I see the realm/region options now. They weren’t showing before and I suspect it had something to do with that. But all is well for now.

    #933
    Taracque
    Member

    This bug has been fixed in 0.6.2.
    Thanks for your contribution!

    Plugin specific parameter labels are loaded once the guild is saved. I’ll put a description there, which describes this behavior.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
 

Comments are closed.