MySQL issue with raidplanner plugin

On , in , by samsunix

Home Forums RaidPlanner Discussions Bug reports MySQL issue with raidplanner plugin

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #673
    samsunix
    Member

    moved from raidplanner – old page
    ————————————————-

    Samuli Latvala says:
    2011/12/13 at 18:31

    I had first problem with armory sync. I solved it by intalling php5-curl on my server. Now sync works great but users cant enymore bind characters to joomla account. Eny ideas?

    I am usin 64bit ubuntu server 11.10, joomla 1.7.3 and I have tryed Taracque-RaidPlanner-0.3.8, Taracque-RaidPlanner-b68da61, Taracque-RaidPlanner-c134c7b with always same result. I have set groups etc but nothing seems to get it going.
    Reply

    Taracque says:
    2011/12/13 at 19:05

    Please post your problem in RaidPlanner Discussions next time!
    How did you tried to bound chars to accounts?
    Do you have RaidPlanner plugin enabled and published in Joomla?
    Reply
    Samuli Latvala says:
    2011/12/13 at 19:17

    It’s not working when:
    1. New user register and apply characters
    2. When old user edits own profile and selects characters and press “submit” button -> Character – No Information Entered
    3. When I manually select user for character from administrator – raidplanner – characters – user name. I still see in profile characters – no information entered.
    Raidplanner plugin is enabled and published

    I have debug on and if you want I can give you account information to log in. Just giev email addres.

    my website is http://routa.dyndns.org/routa/wow
    Reply
    Samuli Latvala says:
    2011/12/13 at 20:42

    I wound error message when trying “database check”:

    500 – An error has occurred.

    JDatabaseMySQL::query: 1146 – Table ‘fucku.rotta_raidplanner_characters’ doesn’t exist SQL=SELECT c.character_id,c.profile_id FROM rotta_raidplanner_characters AS c LEFT JOIN rotta_raidplanner_guild AS g ON g.guild_id = c.guild_id WHERE g.guild_name IS NULL
    Reply
    Samuli Latvala says:
    2011/12/13 at 21:23

    …but thay may be caused by debug mode because when I turn it off it works normally.

    ————————————————————————————————————————–
    Continued:

    I figured out that raidplanner plugin dosnt actually write or read from mysql.
    I checked rotta_raidplanner_character file after trying to add character as normal user from profile and nothing appeared. After I added user charater manually from administrator – raidplanner – charachters. I finally got my name id appeared in mysql database file _raidplanner_character but character name still dosn’t show up in my profile info in web page.

    I have reinstall joomla and raidplanner now 13 times (seriosly, I checked from mysql database) so dont ask me to do it again.
    ———————————————————————————————–
    http://taracque.hu/forums/topic/user-plugin-kunena-compatibility/

    -_-‘

    ———————————————————————————————-

    created fresh joomla 1.7.3 here: http://routa.dyndns.org/routa/gw/ without enything but raidplanner and still same problem so it’s not kunena… I think

    Feel free to try it out: loldin / loldin

    • This topic was modified 9 years, 7 months ago by samsunix.
    • This topic was modified 9 years, 7 months ago by samsunix.
    • This topic was modified 9 years, 7 months ago by samsunix.
    • This topic was modified 9 years, 7 months ago by samsunix.
    • This topic was modified 9 years, 7 months ago by samsunix.
    • This topic was modified 9 years, 7 months ago by samsunix.
    • This topic was modified 9 years, 7 months ago by samsunix.
    • This topic was modified 9 years, 7 months ago by samsunix.
    • This topic was modified 9 years, 7 months ago by samsunix.
    #684
    Taracque
    Member

    The SQL error is a bug in raidplanner, I’ve fixed it, but that shouldn’t make any problems.
    I’ve tried the link what you have provided, and I was able to add character Anam to my profile.
    I’ve added a new account called “test” to your test site. Assign character to that account also works for me. (Character Dexym is assigned to that account)
    I’ll not ask to reinstall anything, as it will not help.
    If you are using kunena for profile editing, you have to change one of kunena’s files, you can see the details here:

    http://www.kunena.org/forum/119-feature-requests/109468-support-of-joomla-user-plugins-in-kunena

    As I see that this K1.7.1 still doesn’t contains this patch, so you have to edit the file yourself.

    • This reply was modified 9 years, 7 months ago by Taracque.
    #686
    samsunix
    Member

    Seems so but only one question left then. How?
    I added user test to group “registered” and I am not able to add eny character from profile edit section. I greated new account via registration and via registration I tryed add characters and still no. I also tryed add user for character manually in administrator page and that works neighter. So how did you do it? and why it dosnt work for me or eny of my guild member who have tryed it? kumena is not issue here because these joomla installation dosnt have it.
    http://routa.dyndns.org/routa/wtf.jpg
    http://routa.dyndns.org/routa/wtf2.jpg

    Ok seems these is browser issue. friend with mac and Crome is able to add characters. Allthou almous everyone in guild uses firefox (including me). Eny fix for these?

    • This reply was modified 9 years, 7 months ago by samsunix.
    • This reply was modified 9 years, 7 months ago by samsunix.
    • This reply was modified 9 years, 7 months ago by samsunix.
    • This reply was modified 9 years, 7 months ago by samsunix.
    #691
    samsunix
    Member

    I tought php5-curl may cause these so I removed it from server and restarted apache but still no. Only synch with armory stopped working so I installed it back and restarted apache again. How ever I confirmed these is browser problem by installing chrome and what you know. It works. I still kinda want these get going with firefox and iexplorer so if someone want to help me, I created for test purpose another fresh joomla 1.7.3 installation here:
    http://routa.dyndns.org/routa/test
    admin / admin

    My real guild website is located here: http://routa.dyndns.org/routa/wow

    #692
    samsunix
    Member

    I got finally some errors. When I am trying to remove character firefox prints:
    rp_characterEditorValue_jform_raidplanner_characters is not defined
    [Break On This Error] document.id(rp_characterEditorValue_…lanner_characters).set(“value”, val);
    profil…ut=edit (line 78)

    http://pastebin.com/2fr52skW
    on these paste error is on line 76
    I hope these helps

    • This reply was modified 9 years, 7 months ago by samsunix.
    • This reply was modified 9 years, 7 months ago by samsunix.
    #695
    Taracque
    Member

    Ok, I’ve fixed that error, Firefox shouldn’t break on this anymore. Update with Joomla updater.
    And let me explain a bit more how it works:
    Assigning character on the backend will not be shown on the fronted for users. So if a user set his/her own characters in profile changes the character ONLY if the character is not assigned to any other players. And if you change a character assignment on the backend it will not change the profile settings of the user. It’s normal, maybe I’ll change it in the future, but now its normal.

    #696
    samsunix
    Member

    Thank you. It works great now. Cant say perfectly thou because it still causes error with basic settings but it is not important. (when I turn off raidplanner_plugin I am able to change basic settings so…)

    #697
    Taracque
    Member

    Can you please post what errors are generated? I would like to fix all errors, but I need to know about it…

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
 

Comments are closed.